System requirements

From Astrolords
Jump to: navigation, search

iOS version

iOS 6.0 or later.

Compatible with iPhone4S, iPad2, and iPod touch. This app is optimized for iPhone 5.


Android version 4.0.3+ is required.

Web version

The players can enter the English version of the game here:

The browser version of the game is compatible with most popular web browsers such as Mozilla Firefox, Internet Explorer, Opera.

To be able to play the game, the user may need to download Unity plugin.


The PC client can be downloaded here:

OS: Windows XP/ Vista/ 7/ 8

Processor: 2GHz Dual Core

Memory: 1 GB RAM

Graphics: N8VIDIA GeForce 6800 or ATI Radeon x1950 or better

Hard Drive: 1 GB available space

Audio: compatible with Direct X 9.0+


Mac OS X 10.6.8+ is required.

The Mac client can be downloaded here:


Ubuntu 12.04 LTS is required.